settings: Replace deprecated YYLEX_PARAM with %lex-param