Allow SHA1_Init()/SHA1_Update() to fail if OpenSSL version >= 1.0