the Linux 2.6.28 uml guest kernel does not need any patches