fuzz: Support build with -fsanitize=fuzzer instead of libFuzzer.a