child-sa: Remove the obsolete update logic