android: Increase the minSdkVersion to 15 and targetSdkVersion to 22