configure: Add global --enable-ruby-gems and --with-rubygemdir options