added support of INVALID_PARAMETER PA-Error