plugin-loader: Correctly read dlopen_use_rtld_now option
authorTobias Brunner <tobias@strongswan.org>
Thu, 14 Sep 2017 10:43:54 +0000 (12:43 +0200)
committerTobias Brunner <tobias@strongswan.org>
Mon, 18 Sep 2017 10:07:26 +0000 (12:07 +0200)
Fixes: 305c4aa82cb0 ("plugin-loader: Optionally use RTLD_NOW with dlopen()")

src/libstrongswan/plugins/plugin_loader.c

index 701049a..7d0cc88 100644 (file)
@@ -438,7 +438,7 @@ static plugin_entry_t *load_plugin(private_plugin_loader_t *this, char *name,
                }
        }
        if (lib->settings->get_bool(lib->settings, "%s.dlopen_use_rtld_now",
-                                                               lib->ns, FALSE))
+                                                               FALSE, lib->ns))
        {
                flag = RTLD_NOW;
        }