github: Remove build on Ubuntu Xenial (16.04)
authorTobias Brunner <tobias@strongswan.org>
Wed, 8 Sep 2021 10:00:12 +0000 (12:00 +0200)
committerTobias Brunner <tobias@strongswan.org>
Thu, 9 Sep 2021 10:30:17 +0000 (12:30 +0200)
Support for it will be removed later this month.

.github/workflows/linux.yml
scripts/test.sh

index b1834a8..9ac3ef0 100644 (file)
@@ -153,43 +153,3 @@ jobs:
           name: Logs ${{ github.job }}
           path: config.log
           retention-days: 5
-
-  xenial:
-    needs: pre-check
-    if: ${{ needs.pre-check.outputs.should_skip != 'true' }}
-    runs-on: ubuntu-16.04
-    strategy:
-      matrix:
-        test: [ all ]
-        compiler: [ gcc, clang ]
-        include:
-          - test: openssl-1.0
-          - test: openssl-1.0
-            leak-detective: yes
-    env:
-      LEAK_DETECTIVE: ${{ matrix.leak-detective || 'no' }}
-      CC: ${{ matrix.compiler || 'gcc' }}
-      TEST: ${{ matrix.test }}
-      # this is the default with newer versions and fixes builds with clang
-      CCACHE_CPP2: true
-    steps:
-      - uses: actions/checkout@v2
-      - uses: actions/cache@v2
-        with:
-          path: ~/.ccache
-          key: ccache-xenial-${{ env.CC }}-${{ matrix.test }}-${{ github.sha }}
-          restore-keys: |
-            ccache-xenial-${{ env.CC }}-${{ matrix.test }}-
-            ccache-xenial-${{ env.CC }}-
-      - run: |
-          sudo apt-get install -qq ccache
-          echo "PATH=/usr/lib/ccache:$PATH" >> $GITHUB_ENV
-          ccache -z
-      - uses: ./.github/actions/default
-      - run: ccache -s
-      - if: ${{ failure() }}
-        uses: actions/upload-artifact@v2
-        with:
-          name: Logs ${{ github.job }}
-          path: config.log
-          retention-days: 5
index 1c0efd6..ddd9db4 100755 (executable)
@@ -168,10 +168,6 @@ all|coverage|sonarcloud)
                # not actually required but configure checks for it
                DEPS="$DEPS lcov"
        fi
-       # Botan requires newer compilers, so disable it on Ubuntu 16.04
-       if [ "$ID" = "ubuntu" -a "$VERSION_ID" = "16.04" ]; then
-               CONFIG="$CONFIG --disable-botan"
-       fi
        DEPS="$DEPS libcurl4-gnutls-dev libsoup2.4-dev libunbound-dev libldns-dev
                  libmysqlclient-dev libsqlite3-dev clearsilver-dev libfcgi-dev
                  libldap2-dev libpcsclite-dev libpam0g-dev binutils-dev libnm-dev
@@ -181,14 +177,9 @@ all|coverage|sonarcloud)
        else
                DEPS="$DEPS iptables-dev python3-setuptools"
        fi
-       # tox has dependencies that can't be resolved on 16.04 (even with pip)
-       if [ "$ID" != "ubuntu" -o "$VERSION_ID" != "16.04" ]; then
-               PYDEPS="tox"
-       fi
+       PYDEPS="tox"
        if test "$1" = "build-deps"; then
-               if [ "$ID" != "ubuntu" -o "$VERSION_ID" != "16.04" ]; then
-                       build_botan
-               fi
+               build_botan
                build_wolfssl
                build_tss2
        fi