vici: Update supported Python versions
authorTobias Brunner <tobias@strongswan.org>
Wed, 8 Sep 2021 09:55:41 +0000 (11:55 +0200)
committerTobias Brunner <tobias@strongswan.org>
Thu, 9 Sep 2021 10:30:17 +0000 (12:30 +0200)
src/libcharon/plugins/vici/python/setup.py.in
src/libcharon/plugins/vici/python/tox.ini

index 9ef0011..8f0c021 100644 (file)
@@ -14,21 +14,18 @@ setup(
     license="MIT",
     packages=["vici"],
     include_package_data=True,
-    classifiers=(
+    classifiers=[
         "Development Status :: 5 - Production/Stable",
         "Intended Audience :: Developers",
         "Intended Audience :: System Administrators",
         "License :: OSI Approved :: MIT License",
         "Natural Language :: English",
         "Programming Language :: Python :: 2.7",
-        "Programming Language :: Python :: 3.2",
-        "Programming Language :: Python :: 3.3",
-        "Programming Language :: Python :: 3.4",
-        "Programming Language :: Python :: 3.5",
         "Programming Language :: Python :: 3.6",
         "Programming Language :: Python :: 3.7",
         "Programming Language :: Python :: 3.8",
+        "Programming Language :: Python :: 3.9",
         "Topic :: Security",
         "Topic :: Software Development :: Libraries",
-    )
+    ]
 )
index 2000478..7b058d5 100644 (file)
@@ -1,5 +1,5 @@
 [tox]
-envlist = py27, py35, py36, py37, py38
+envlist = py27, py36, py37, py38, py39
 
 [testenv]
 deps =
@@ -7,7 +7,7 @@ deps =
        pytest-pycodestyle
 commands = pytest --pycodestyle
 
-[testenv:py{27,35}]
+[testenv:py{27}]
 deps = pytest
 commands = pytest