Support "_" and "-" variants of NetworkManager pkg-config packages
authorMartin Willi <martin@strongswan.org>
Tue, 8 Dec 2009 13:35:16 +0000 (14:35 +0100)
committerMartin Willi <martin@strongswan.org>
Tue, 8 Dec 2009 13:36:22 +0000 (14:36 +0100)
configure.in
src/charon/plugins/nm/gnome/configure.ac

index a8818a9..2c2ffaf 100644 (file)
@@ -517,7 +517,10 @@ if test x$uci = xtrue; then
 fi
 
 if test x$nm = xtrue; then
-       PKG_CHECK_MODULES(nm, [NetworkManager libnm_glib_vpn gthread-2.0])
+       PKG_CHECK_EXISTS([libnm-glib],
+               [PKG_CHECK_MODULES(nm, [NetworkManager gthread-2.0 libnm-glib libnm-glib-vpn])],
+               [PKG_CHECK_MODULES(nm, [NetworkManager gthread-2.0 libnm_glib libnm_glib_vpn])]
+       )
        AC_SUBST(nm_CFLAGS)
        AC_SUBST(nm_LIBS)
 fi
index ffa3c82..7a88603 100644 (file)
@@ -76,7 +76,10 @@ if test x"$with_gnome" != xno; then
        AC_SUBST(GNOMEKEYRING_LIBS)
 fi
 
-PKG_CHECK_MODULES(NM_UTILS, NetworkManager >= 0.7.0 libnm-util libnm_glib libnm_glib_vpn)
+PKG_CHECK_EXISTS([libnm-glib],
+       [PKG_CHECK_MODULES(NM_UTILS, NetworkManager >= 0.7.0 libnm-util libnm-glib libnm-glib-vpn)],
+       [PKG_CHECK_MODULES(NM_UTILS, NetworkManager >= 0.7.0 libnm-util libnm_glib libnm_glib_vpn)]
+)
 AC_SUBST(NM_UTILS_CFLAGS)
 AC_SUBST(NM_UTILS_LIBS)