android: New release based on 5.1.1
authorTobias Brunner <tobias@strongswan.org>
Wed, 13 Nov 2013 16:41:24 +0000 (17:41 +0100)
committerTobias Brunner <tobias@strongswan.org>
Wed, 13 Nov 2013 16:41:24 +0000 (17:41 +0100)
This fixes issues with IVs and padding in ESP handling and removes the
Vstr dependency.

src/frontends/android/.classpath
src/frontends/android/AndroidManifest.xml

index 3f9691c..d57ec02 100644 (file)
@@ -1,8 +1,9 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <classpath>
        <classpathentry kind="con" path="com.android.ide.eclipse.adt.ANDROID_FRAMEWORK"/>
-       <classpathentry kind="con" path="com.android.ide.eclipse.adt.LIBRARIES"/>
+       <classpathentry exported="true" kind="con" path="com.android.ide.eclipse.adt.LIBRARIES"/>
        <classpathentry kind="src" path="src"/>
        <classpathentry kind="src" path="gen"/>
+       <classpathentry exported="true" kind="con" path="com.android.ide.eclipse.adt.DEPENDENCIES"/>
        <classpathentry kind="output" path="bin/classes"/>
 </classpath>
index 11d9eaa..8898c59 100644 (file)
 -->
 <manifest xmlns:android="http://schemas.android.com/apk/res/android"
     package="org.strongswan.android"
-    android:versionCode="17"
-    android:versionName="1.3.2" >
+    android:versionCode="18"
+    android:versionName="1.3.3" >
 
-    <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="17" />
+    <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="18" />
 
     <uses-permission android:name="android.permission.INTERNET" />
     <uses-permission android:name="android.permission.ACCESS_NETWORK_STATE" />