openssl: Avoid conflicts with wincrypt.h on Windows
authorTobias Brunner <tobias@strongswan.org>
Tue, 26 Jan 2021 10:17:20 +0000 (11:17 +0100)
committerTobias Brunner <tobias@strongswan.org>
Wed, 27 Jan 2021 15:32:43 +0000 (16:32 +0100)
There are several conflicts with newer versions of OpenSSL (> 1.0).

src/libstrongswan/plugins/openssl/Makefile.am

index f488bc1..b1073ed 100644 (file)
@@ -2,6 +2,10 @@ AM_CPPFLAGS = \
        -I$(top_srcdir)/src/libstrongswan \
        -DFIPS_MODE=${fips_mode}
 
+if USE_WINDOWS
+AM_CPPFLAGS += -DNOCRYPT
+endif
+
 AM_CFLAGS = \
        $(PLUGIN_CFLAGS)