android: Keep NDK API level at 19
authorTobias Brunner <tobias@strongswan.org>
Mon, 27 Jul 2015 15:46:06 +0000 (17:46 +0200)
committerTobias Brunner <tobias@strongswan.org>
Tue, 28 Jul 2015 11:27:34 +0000 (13:27 +0200)
The headers/libraries changed a lot with level 21 so that our app won't
run on devices with Android < 5 when built against it.  We currently
don't need any new native APIs so that should be fine.

src/frontends/android/jni/Application.mk

index cdfb474..9fa6683 100644 (file)
@@ -1,2 +1,3 @@
 # select the ABI(s) to build for (see CPU-ARCH-ABIS.html in the NDK docs).
 APP_ABI := armeabi x86 mips
+APP_PLATFORM := android-19