The kernel-klips plugin does currently not support SAD/SPD flushing.
authorTobias Brunner <tobias@strongswan.org>
Fri, 21 Oct 2011 11:44:17 +0000 (13:44 +0200)
committerTobias Brunner <tobias@strongswan.org>
Fri, 21 Oct 2011 12:24:33 +0000 (14:24 +0200)
src/libhydra/plugins/kernel_klips/kernel_klips_ipsec.c

index 25287aa..ceff8cd 100644 (file)
@@ -2589,9 +2589,11 @@ kernel_klips_ipsec_t *kernel_klips_ipsec_create()
                                .update_sa = _update_sa,
                                .query_sa = _query_sa,
                                .del_sa = _del_sa,
                                .update_sa = _update_sa,
                                .query_sa = _query_sa,
                                .del_sa = _del_sa,
+                               .flush_sas = (void*)return_failed,
                                .add_policy = _add_policy,
                                .query_policy = _query_policy,
                                .del_policy = _del_policy,
                                .add_policy = _add_policy,
                                .query_policy = _query_policy,
                                .del_policy = _del_policy,
+                               .flush_policies = (void*)return_failed,
                                .bypass_socket = _bypass_socket,
                                .destroy = _destroy,
                        },
                                .bypass_socket = _bypass_socket,
                                .destroy = _destroy,
                        },