plugin name is x509
[strongswan.git] / src / libstrongswan / plugins / x509 / x509_cert.c
index fc68cdc..839d102 100644 (file)
@@ -906,7 +906,7 @@ static bool parse_certificate(private_x509_cert_t *this)
                                                break;
                                        default:
                                                if (critical && lib->settings->get_bool(lib->settings,
-                                                       "libstrongswan.plugins.x509_cert.enforce_critical", FALSE))
+                                                       "libstrongswan.plugins.x509.enforce_critical", FALSE))
                                                {
                                                        DBG1("critical %s extension not supported",
                                                                 (extn_oid == OID_UNKNOWN) ? "unknown" :