pkcs12: Add plugin dependencies with soft dependencies on the most common algorithms
[strongswan.git] / src / libstrongswan / plugins / dnskey / Makefile.am
index 9c8e612..0f2e554 100644 (file)
@@ -7,10 +7,11 @@ if MONOLITHIC
 noinst_LTLIBRARIES = libstrongswan-dnskey.la
 else
 plugin_LTLIBRARIES = libstrongswan-dnskey.la
-libstrongswan_dnskey_la_LIBADD = $(top_builddir)/src/libstrongswan/libstrongswan.la
 endif
 
-libstrongswan_dnskey_la_SOURCES = dnskey_plugin.h dnskey_plugin.c \
-  dnskey_builder.h dnskey_builder.c
+libstrongswan_dnskey_la_SOURCES = \
+       dnskey_plugin.h dnskey_plugin.c \
+       dnskey_builder.h dnskey_builder.c \
+       dnskey_encoder.h dnskey_encoder.c
 
 libstrongswan_dnskey_la_LDFLAGS = -module -avoid-version