configure: Use pkg-config to detect libiptc used by connmark/forecast
[strongswan.git] / src / libcharon / plugins / connmark / Makefile.am
index c70f529..cc4d0ec 100644 (file)
@@ -4,7 +4,7 @@ AM_CPPFLAGS = \
        -I$(top_srcdir)/src/libcharon
 
 AM_CFLAGS = \
-       $(PLUGIN_CFLAGS)
+       $(PLUGIN_CFLAGS) $(libiptc_CFLAGS)
 
 if MONOLITHIC
 noinst_LTLIBRARIES = libstrongswan-connmark.la
@@ -17,4 +17,4 @@ libstrongswan_connmark_la_SOURCES = \
        connmark_plugin.h connmark_plugin.c
 
 libstrongswan_connmark_la_LDFLAGS = -module -avoid-version
-libstrongswan_connmark_la_LIBADD = -lip4tc
+libstrongswan_connmark_la_LIBADD = $(libiptc_LIBS)