android: Fix database upgrade from older versions
[strongswan.git] / .travis.yml
index d39c9cb..7e70df5 100644 (file)
@@ -1,14 +1,12 @@
 language: c
 
 sudo: required
-dist: trusty
+dist: xenial
 
 # don't build tags separately
 if: tag IS blank
 
-compiler:
-  - gcc
-  - clang
+compiler: gcc
 
 cache: ccache
 
@@ -29,53 +27,64 @@ after_success:
 
 after_failure:
   - cat config.log
+  - sleep 1
 
 env:
   global:
     - TESTS_REDUCED_KEYLENGTHS=yes
     - LEAK_DETECTIVE=no
     - MONOLITHIC=no
-  matrix:
-    - TEST=all
-    - TEST=all MONOLITHIC=yes
-    - TEST=all LEAK_DETECTIVE=yes
-    - TEST=default
-    - TEST=default MONOLITHIC=yes
-    - TEST=default LEAK_DETECTIVE=yes
-    - TEST=botan
-    - TEST=botan LEAK_DETECTIVE=yes
-    - TEST=openssl
-    - TEST=openssl LEAK_DETECTIVE=yes
-    - TEST=gcrypt
-    - TEST=gcrypt LEAK_DETECTIVE=yes
-    # we can't test Vstr as negative int args are not properly passed to CBs
-    - TEST=printf-builtin
-    - TEST=printf-builtin LEAK_DETECTIVE=yes
 
 matrix:
   include:
-    - compiler: clang
-      os: osx
-      env: TEST=osx
-    - compiler: gcc
-      env: TEST=sonarcloud
+    - env: TEST=sonarcloud
+      if: type = push AND env(SONAR_TOKEN) IS present
       git:
         depth: false
       addons:
         sonarcloud:
           organization: "strongswan"
-    - compiler: gcc
-      env: TEST=coverage
-    - compiler: clang
-      env: TEST=fuzzing MONOLITHIC=yes
-    - compiler: gcc
-      env: TEST=dist
-    - compiler: gcc
-      env: TEST=apidoc
-    - compiler: gcc
-      env: TEST=win64 MONOLITHIC=yes
-    # this does not work on 14.04 due to a missing @4 decoration for
-    # TryAcquireSRWLockExclusive in MinGW 3.1.0
-    - compiler: gcc
-      env: TEST=win32 MONOLITHIC=yes
-      dist: precise
+    - env: TEST=osx
+      compiler: clang
+      os: osx
+    - env: TEST=all
+    - env: TEST=all
+      compiler: clang
+    - env: TEST=all MONOLITHIC=yes
+    - env: TEST=all MONOLITHIC=yes
+      compiler: clang
+    - env: TEST=all LEAK_DETECTIVE=yes
+    - env: TEST=all LEAK_DETECTIVE=yes
+      compiler: clang
+    - env: TEST=coverage
+    - env: TEST=fuzzing MONOLITHIC=yes
+      compiler: clang
+    - env: TEST=win64 MONOLITHIC=yes
+    - env: TEST=win32 MONOLITHIC=yes
+    - env: TEST=dist
+    # "default" with GCC is already tested with "dist" above
+    - env: TEST=default
+      compiler: clang
+    - env: TEST=default MONOLITHIC=yes
+    - env: TEST=default MONOLITHIC=yes
+      compiler: clang
+    - env: TEST=default LEAK_DETECTIVE=yes
+    - env: TEST=default LEAK_DETECTIVE=yes
+      compiler: clang
+    # we can't test Vstr as negative int args are not properly passed to CBs
+    - env: TEST=printf-builtin
+    - env: TEST=printf-builtin
+      compiler: clang
+    - env: TEST=printf-builtin LEAK_DETECTIVE=yes
+    - env: TEST=printf-builtin LEAK_DETECTIVE=yes
+      compiler: clang
+    # the crypto plugins are build-tested with clang via "all" above
+    - env: TEST=botan
+    - env: TEST=botan LEAK_DETECTIVE=yes
+    - env: TEST=openssl
+    - env: TEST=openssl LEAK_DETECTIVE=yes
+    - env: TEST=openssl-1.0
+    - env: TEST=openssl-1.0 LEAK_DETECTIVE=yes
+    - env: TEST=gcrypt
+    - env: TEST=gcrypt LEAK_DETECTIVE=yes
+    - env: TEST=apidoc