Dropped support of deprecated authby=eap and eap= options
[strongswan.git] / src / stroke / Makefile.am
1 ipsec_PROGRAMS = stroke
2
3 stroke_SOURCES = \
4 stroke.c stroke_msg.h stroke_keywords.c stroke_keywords.h
5
6 stroke_LDADD = $(top_builddir)/src/libstrongswan/libstrongswan.la $(SOCKLIB)
7 INCLUDES = -I$(top_srcdir)/src/libstrongswan
8 EXTRA_DIST = stroke_keywords.txt
9 BUILT_SOURCES = stroke_keywords.c
10 MAINTAINERCLEANFILES = stroke_keywords.c
11 AM_CFLAGS = -DIPSEC_PIDDIR=\"${piddir}\"
12
13 stroke_keywords.c:      $(srcdir)/stroke_keywords.txt $(srcdir)/stroke_keywords.h
14                 $(GPERF) -m 10 -D -C -G -t < $(srcdir)/stroke_keywords.txt > $@