scepclient: Use pkcs7_t and pkcs9_t, remove all dependencies to pluto/libfreeswan.
[strongswan.git] / src / scepclient / Makefile.am
1 ipsec_PROGRAMS = scepclient
2 scepclient_SOURCES = scepclient.c scep.c scep.h
3
4 scepclient.o :  $(top_builddir)/config.status
5
6 INCLUDES = \
7 -I$(top_srcdir)/src/libstrongswan \
8 -I$(top_srcdir)/src/libhydra
9
10 AM_CFLAGS = \
11 -DIPSEC_CONFDIR=\"${sysconfdir}\" \
12 -DPLUGINS=\""${scepclient_plugins}\""
13
14 scepclient_LDADD = \
15 $(top_builddir)/src/libstrongswan/libstrongswan.la
16
17 # This compile option activates smartcard support
18 if USE_SMARTCARD
19   AM_CFLAGS += -DSMARTCARD
20   scepclient_LDADD += $(DLLIB)
21 endif
22
23 dist_man_MANS = scepclient.8
24