added -avoid-version to LDFLAGS, plugins are not versioned
[strongswan.git] / src / libstrongswan / plugins / openssl / Makefile.am
1
2 INCLUDES = -I$(top_srcdir)/src/libstrongswan
3
4 AM_CFLAGS = -rdynamic
5
6 plugin_LTLIBRARIES = libstrongswan-openssl.la
7
8 libstrongswan_openssl_la_SOURCES = openssl_plugin.h openssl_plugin.c \
9         openssl_util.c openssl_util.h \
10         openssl_crypter.c openssl_crypter.h \
11         openssl_hasher.c openssl_hasher.h \
12         openssl_diffie_hellman.c openssl_diffie_hellman.h \
13         openssl_rsa_private_key.c openssl_rsa_private_key.h \
14         openssl_rsa_public_key.c openssl_rsa_public_key.h \
15         openssl_ec_diffie_hellman.c openssl_ec_diffie_hellman.h \
16         openssl_ec_private_key.c openssl_ec_private_key.h \
17         openssl_ec_public_key.c openssl_ec_public_key.h
18
19 libstrongswan_openssl_la_LDFLAGS = -module -avoid-version
20 libstrongswan_openssl_la_LIBADD  = -lcrypto
21