added -avoid-version to LDFLAGS, plugins are not versioned
[strongswan.git] / src / libstrongswan / plugins / gcrypt / Makefile.am
1
2 INCLUDES = -I$(top_srcdir)/src/libstrongswan
3
4 AM_CFLAGS = -rdynamic $(LIBGCRYPT_CFLAGS)
5
6 plugin_LTLIBRARIES = libstrongswan-gcrypt.la
7
8 libstrongswan_gcrypt_la_SOURCES = gcrypt_plugin.h gcrypt_plugin.c \
9         gcrypt_rsa_public_key.h gcrypt_rsa_public_key.c \
10         gcrypt_rsa_private_key.h gcrypt_rsa_private_key.c \
11         gcrypt_dh.h gcrypt_dh.c \
12         gcrypt_rng.h gcrypt_rng.c \
13         gcrypt_crypter.h gcrypt_crypter.c \
14         gcrypt_hasher.h gcrypt_hasher.c
15
16 libstrongswan_gcrypt_la_LDFLAGS = -module -avoid-version
17 libstrongswan_gcrypt_la_LIBADD  = $(LIBGCRYPT_LIBS)