removed dependencies from libtnc
[strongswan.git] / src / libcharon / plugins / tnccs_20 / Makefile.am
1
2 INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/libhydra \
3         -I$(top_srcdir)/src/libcharon -I$(top_srcdir)/src/libtls \
4         `xml2-config --cflags`
5
6 AM_CFLAGS = -rdynamic
7
8 if MONOLITHIC
9 noinst_LTLIBRARIES = libstrongswan-tnccs-20.la
10 else
11 plugin_LTLIBRARIES = libstrongswan-tnccs-20.la
12 libstrongswan_tnccs_20_la_LIBADD = $(top_builddir)/src/libtls/libtls.la
13 endif
14
15 libstrongswan_tnccs_20_la_SOURCES = \
16         tnccs_20_plugin.h tnccs_20_plugin.c tnccs_20.h tnccs_20.c
17
18 libstrongswan_tnccs_20_la_LDFLAGS = -module -avoid-version
19