Migrated NM frontend plugin to NetworkManager 0.9
[strongswan.git] / src / frontends / gnome / properties / Makefile.am
1 plugindir = $(libdir)/NetworkManager
2 plugin_LTLIBRARIES = libnm-strongswan-properties.la
3
4 libnm_strongswan_properties_la_SOURCES = \
5         nm-strongswan.c \
6         nm-strongswan.h
7
8 uidir = $(datadir)/gnome-vpn-properties/strongswan
9 ui_DATA = nm-strongswan-dialog.ui
10
11 libnm_strongswan_properties_la_CFLAGS = \
12         $(GTK_CFLAGS) \
13         $(NM_UTILS_CFLAGS) \
14         -DUIDIR=\""$(uidir)"\" \
15         -DG_DISABLE_DEPRECATED \
16         -DGDK_DISABLE_DEPRECATED \
17         -DVERSION=\"$(VERSION)\"
18
19 libnm_strongswan_properties_la_LIBADD =      \
20         $(GTK_LIBS) \
21         $(NM_UTILS_LIBS)
22
23 libnm_strongswan_properties_la_LDFLAGS =     \
24         -avoid-version
25
26 EXTRA_DIST = $(ui_DATA)