android: Update Gradle plugin and wrapper
[strongswan.git] / src / frontends / android / app / build.gradle
1 apply plugin: 'com.android.application'
2
3 android {
4     compileSdkVersion 23
5     buildToolsVersion '25.0.0'
6
7     defaultConfig {
8         applicationId "org.strongswan.android"
9         minSdkVersion 15
10         targetSdkVersion 22
11         versionCode 42
12         versionName "1.8.2"
13     }
14
15     sourceSets.main {
16         jni.srcDirs = [] // disables the default ndk-build call (with on-the-fly Android.mk files)
17         jniLibs.srcDir 'src/main/libs'
18     }
19
20     task buildNative(type: Exec) {
21         workingDir 'src/main/jni'
22         commandLine "${android.ndkDirectory}/ndk-build", '-j', Runtime.runtime.availableProcessors()
23     }
24
25     task cleanNative(type: Exec) {
26         workingDir 'src/main/jni'
27         commandLine "${android.ndkDirectory}/ndk-build", 'clean'
28     }
29
30     tasks.withType(JavaCompile) {
31         compileTask -> compileTask.dependsOn buildNative
32         options.compilerArgs << "-Xlint:unchecked" << "-Xlint:deprecation"
33     }
34
35     clean.dependsOn 'cleanNative'
36
37     buildTypes {
38         release {
39             minifyEnabled false
40             proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt'
41         }
42     }
43 }
44
45 dependencies {
46     compile 'com.android.support:appcompat-v7:23.3.0'
47     compile 'com.android.support:design:23.3.0'
48     testCompile 'junit:junit:4.12'
49 }