scepclient requires libcrypto to build
[strongswan.git] / src / Makefile.am
1 SUBDIRS = . include
2
3 if USE_FILE_CONFIG
4   SUBDIRS += libfreeswan starter ipsec _copyright
5 endif
6
7 if USE_LIBSTRONGSWAN
8   SUBDIRS += libstrongswan
9 endif
10
11 if USE_PLUTO
12   SUBDIRS += libcrypto pluto whack
13 endif
14
15 if USE_CHARON
16   SUBDIRS += charon
17 endif
18
19 if USE_STROKE
20   SUBDIRS += stroke
21 endif
22
23 if USE_UPDOWN
24   SUBDIRS += _updown _updown_espmark
25 endif
26
27 if USE_TOOLS
28   SUBDIRS += libcrypto openac scepclient
29 endif
30
31 if USE_DUMM
32   SUBDIRS += dumm
33 endif
34
35 if USE_FAST
36   SUBDIRS += libfast
37 endif
38
39 if USE_MANAGER
40   SUBDIRS += manager
41 endif
42
43 if USE_MEDSRV
44   SUBDIRS += medsrv
45 endif
46
47 EXTRA_DIST = strongswan.conf
48
49 install-exec-local :    
50                 test -e "$(DESTDIR)${sysconfdir}" || $(INSTALL) -d "$(DESTDIR)$(sysconfdir)"
51                 test -e "$(DESTDIR)$(sysconfdir)/strongswan.conf" || $(INSTALL) -o ${ipsecuser} -g ${ipsecgroup} -m 640 strongswan.conf $(DESTDIR)$(sysconfdir)/strongswan.conf || true