Install dev headers only if --with-dev-headers= option is set
[strongswan.git] / Makefile.am
1 SUBDIRS = src man init testing
2
3 if USE_SCRIPTS
4   SUBDIRS += scripts
5 endif
6
7 ACLOCAL_AMFLAGS = -I m4/config
8
9 EXTRA_DIST = Doxyfile.in LICENSE Android.mk.in Android.mk
10 CLEANFILES = Doxyfile
11 BUILT_SOURCES = Android.mk
12 MAINTAINERCLEANFILES = Android.mk
13
14 if USE_DEV_HEADERS
15 config_includedir = $(ipseclibdir)/include
16 nodist_config_include_HEADERS = config.h
17 endif
18
19 Android.mk :    Android.mk.in configure.in
20                 sed \
21                 -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
22                 $(srcdir)/$@.in > $@
23
24 Doxyfile :      Doxyfile.in
25                 sed \
26                 -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
27                 -e "s:\@PACKAGE_NAME\@:$(PACKAGE_NAME):" \
28                 -e "s:\@SRC_DIR\@:$(srcdir):" \
29                 $(srcdir)/$@.in > $@
30
31 apidoc :        Doxyfile
32                 doxygen
33
34 clean-local:
35                 rm -rf apidoc