gmp: Don't parse PKCS1 v1.5 RSA signatures to verify them
[strongswan.git] / .travis.yml
1 language: c
2
3 sudo: required
4 dist: trusty
5
6 compiler:
7   - gcc
8   - clang
9
10 cache: ccache
11
12 before_install:
13   - travis_retry ./scripts/test.sh deps
14   - travis_retry ./scripts/test.sh pydeps
15
16 before_script:
17   - sudo sysctl -w net.ipv6.conf.all.disable_ipv6=0 || true
18
19 script:
20   - ./scripts/test.sh
21
22 after_success:
23   if [ "$TEST" == "coverage" ]; then
24     bash <(curl -s https://codecov.io/bash);
25   fi
26
27 after_failure:
28   - cat config.log
29
30 env:
31   global:
32     - TESTS_REDUCED_KEYLENGTHS=yes
33     - LEAK_DETECTIVE=no
34     - MONOLITHIC=no
35   matrix:
36     - TEST=all
37     - TEST=all MONOLITHIC=yes
38     - TEST=all LEAK_DETECTIVE=yes
39     - TEST=default
40     - TEST=default MONOLITHIC=yes
41     - TEST=default LEAK_DETECTIVE=yes
42     - TEST=botan
43     - TEST=botan LEAK_DETECTIVE=yes
44     - TEST=openssl
45     - TEST=openssl LEAK_DETECTIVE=yes
46     - TEST=gcrypt
47     - TEST=gcrypt LEAK_DETECTIVE=yes
48     # we can't test Vstr as negative int args are not properly passed to CBs
49     - TEST=printf-builtin
50     - TEST=printf-builtin LEAK_DETECTIVE=yes
51
52 matrix:
53   include:
54     - compiler: clang
55       os: osx
56       env: TEST=osx
57     - compiler: gcc
58       env: TEST=sonarcloud
59       git:
60         depth: false
61       addons:
62         sonarcloud:
63           organization: "strongswan"
64     - compiler: gcc
65       env: TEST=coverage
66     - compiler: clang
67       env: TEST=fuzzing MONOLITHIC=yes
68     - compiler: gcc
69       env: TEST=dist
70     - compiler: gcc
71       env: TEST=apidoc
72     - compiler: gcc
73       env: TEST=win64 MONOLITHIC=yes
74     # this does not work on 14.04 due to a missing @4 decoration for
75     # TryAcquireSRWLockExclusive in MinGW 3.1.0
76     - compiler: gcc
77       env: TEST=win32 MONOLITHIC=yes
78       dist: precise